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1 Introduction

AquaSim is an analysis tool developed by Aquastructures AS. It uses the Finite Element Method
(FEM) for calculation and simulation of structural response. The software is well suited for slender,
lightweight- and large volume structures, flexible configurations and coupled systems exposed to
environmental loads such as:

- waves

- currents

- wind

- impulse loads

- operational conditions
- resonance

This manual describes the functionality of the post processing tool AquaTool. AquaTool processes
.AVS-files and may be used to retrieve results for nodes and elements.

Similar properties of the numerical model as found in AquaView can be found in AquaTool, however
the presentation of the data is different. While AquaView visualize results in colours on top of a
model, AquaTool presents results as numerical values. The values are presented either as a single
value from a specific time step, or as a plot from several time steps.
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2 Interface
2.1 Main View

When loading AquaTool, the main view will look as presented in Figure 1.

Bd [Application.title not specified] - O *

File Analysic Data Help

Project status

Loaded files Often used tasks

run_01,AVS™ Elements
T:47V: 2506 Ex 1320 C: 8
Max

Get element max Von Mises stress for 2 series of timesteps in all datasets

Components

Breaking loads
Graph zll brezking loads for components

Max & min values
Get max and min values per component

Other

Sea movement
Diravis 2 graph of the most likely sea node

Calculated Sea movement
Drzws 2 graph of the s22 movement

Load file. .. Unload file Add new pane... Run

run_01.AVS | 47 steps | 2506 vertexes | 1320 elements | 8 components

Figure 1 The main view in AquaTool

Project Status provides information about which files has been loaded and often used tasks in
AquaTool. More detailed description about the properties are presented in Table 1.

Table 1 Main properties in AquaTool

Property Definition

File Provides access to load .AVS-files and exit the program.

Analysis Allows for information about dataset (e.i. information of the different components
in the model) and open the .AVS-file in AquaView.

Data Provides access to view results for nodes, elements, meshes and components.

Loaded files  Presents overview of which .AVS-files is loaded into AquaTool.
Often used Shortcut for accessing often used functions and tasks.

tasks
Run Click to run the chosen task from Often used tasks.
Load file Shortcut for loading .AVS-file into AquaTool.
Unload Shortcut for omitting selected .AVSfiles.
Add new Adds a new pane, to ease presentation of datasets.
pane
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2.2 Loading .AVS-files

Loading .AVS-files is easy, and can be done in several ways:

o File > Open > Navigate to folder for .AVS-file.

o Use the shortcut Load file... and navigate to folder for .AVS-file.
o Drag-and-drop .AVS-file into section for Loaded files, as illustrated in Figure 2.

File Analysis Data Help

Project status

Loaded files

E:d [Application title not specified]

Often used tasks

[m] X

— flytting

Elements

Max
(Get element mai Vion Mises stress for 2 series of timesteps in 2l datasets

Components

Breaking loads
Graph 21l bresking loads for components

Max & min values
Get max and min values per component

Other

Sea movement
Draws = graph of the most Tkely s=3 node

Calculated Sea movement
Drawiz 2 graph of the se2 mavamant

Load file... Unload file

Add new pane...

Figure 2 Loading .AVS-file through drag-and-drop

aquastructures

Having loaded file, status of number of timesteps in the simulation, vertexes, elements and
components are shown in the lower left corner, Figure 3.

{multiple files) | 47 steps | 2506 ve

Ed [Application title not specified] O X
File Analysis Data Help
Status

Project status

Loaded files Often used tasks

run_01.AV5* Elements

T:47W: 2506 E: 1320 C: 8
Max

run_02.AVS* Get element max Vion Mises stress for 2 series of timesteps in il datasets

T:47W: 2506 E: 1320 C: 8

Components
Breaking loads
Graph all brazking lozds for componants
Max & min values
Get max and min values per component
Other
Sea movement
Dravis 2 graph of the most lkely sea node
Calculated Sea movement
Draws 2 graph of the sea movement
Load file... Unload file Add new pane... Run

Figure 3 Loaded .AVS-files in AquaTool
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2.3 Unload .AVS-files

A useful feature in AquaTool, is that several .AVS-files may be loaded. This allows the user to plot
results from different runs and compare values. If the user wishes to remove one file from AquaTool,
click on the relevant file in the Loaded files-section and choose Unload File.

Ed [Application title not specified] — O X
File Analysis Data Help

Status

Project status

Loaded files Often used tasks

run_01.AV5* Elements
T:47V: 2506 E: 1320 C: 8
Max

run_D2.AVS* Get glemant max Vion Mises stress for a series of timesteps in 2l datassts

T:47W: 2506 E: 1320 C: 8

Components

Breaking loads
Graph all brazking lozds for componants

Max & min values
Get max and min values per component

Other

Sea movement
Dravis 2 graph of the most lkely sea node

Calculated Sea movement
Draws 2 graph of the sez movement

Load file... Unload file Add new pane... Run

(multiple files) | 47 steps | 2506 320 elements | 8 components

Figure 4 Unload .AVS-file

2.4 Data Menu bar

AquaTool allows for plotting results in tabular form and graphing as function of the simulated time-
steps. Having loaded .AVS-files the user may extract results from the Data Menu bar.

An AquaSim-model is built up by elements, connected through nodes. The elements may be
expressed as a beam, membrane, truss or Node2Node spring. The collective term of the different
ways of expressing elements, is Components or Component group. For more detailed information,
reference is made to the AquaEdit User Manual. Upon exporting the AquaSim-model in AquaEdit,
unique ID-numbers are generated for each node and element. These ID-numbers enables extracting
results in AquaTool.

The Data Menu bar provides much the same result types as found in AquaView, with some
limitations. Results may be extracted from Nodes, Elements, Meshes (membrane), or on a more
general level, for Components. Example of the different types of results available for Element, is
shown in Figure 5. For more information about the different result types, reference is made to the
AquaView User Manual.
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E:d [Application title not specified] - m} *
File Analysis Data Help

Status MNodes >
) Elements b Convergence norm
Project s
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run_01.AVS™

T: 47 V: 2506 E: 1320 C: & PUNKT3
Rotation | stress for 3 series of timesteps in 2l datassts
Stress comnponent ¥

Von Mises stresz [MPa]
r components
Calculated
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Other

Sea movement
Draws = graph of the most Tkely s=3 node

Calculated Sea movement
Drawiz 2 graph of the se2 mavamant

Load file... Unload file Add new pane...

{multiple files) | 47 steps | 2506

Figure 5 The Data menu bar

2.5 Analysis menu bar

The Analysis-menu provides the user access to information about the AquaSim-model, and allows
the user to open the .AVS-file in AquaView through AquaTool.

Show dataset information provides basic information about the different components in the
AquaSim-model. In the Components section, click on the element to view the element ID-number

and other information such as breaking load, line width and cross section coordinates. This is
illustrated in Figure 6.

Bd [Application title not specified] - [m} *
File = Analysic Data Help
Stai Show dataset information
rur Open in AquaView
Components Elements
Collar 3500 SDR13.6 1 ~
Ring 2
Met 3
Lice skirt 4
Moaring line 5
Chain 6
Frame 7
Crow feet 3
el
10
11
12
13 v
Other information
0.073 -0.177 s
0.001-0.02
-0.001-0.02
-0.073-0.177
-0.25-0.25
0,427 0,177
-0.50.0
-0.427 0,177
-0.250.25
v

{multiple fi

Figure 6 Show dataset information
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3 Plotting results

Results may be extracted from the Data Menu bar. AquaTool display different menu options
depending if a file contains several timesteps (.AVS) or as a maximum-file (PFAT.AVS).

3.1 Query properties

Selecting a result type from the Data-menu opens the window Query properties, as shown in Figure
7. In the field Range/Tagname the ID-number of node or element is specified. It can either be a
single ID-number, or a range of several numbers. For displaying results for a single node/element,
type the ID-number (found e.g. in AquaView by clicking the relevant node/element). For a range,
enter two numbers separated by a dash, e.g. 430-440. For several ID-numbers, but not next to each
other, separate the values by comma, e.g. 433, 436. More information about the subsequent options
are presented in Table 2.

BEd Query properties >
Range /Tagname
Dataset |<<all=> v
Stress/datatype |h'n:nn_|'~"lises_s1:|'ess_[l'v‘lPa] o
Mode |DATA_MODE_MAX o
[] Separate tabs
save def, Cancel

Figure 7 Window for extracting results

Table 2 Options under Query properties

Options Definition
Range/Tagname Type the ID-number of node or elements. Several ID-numbers may be specified.
Dataset Choose witch loaded .AVS-file to extract results.

Stress/datatype Choose what type of results to be presented. E.g. global section forces, local
section forces, Von Mises etc. For more information on the result types,
reference is made to AquaView User Manual. This option equals the selection of
different menu-options from Data-menu.

Mode Choose the level or position of results between two nodes (node A and B) that
constitutes an element.

o DATA_MODE_MAX: presents the maximum value of the two nodes.

o DATA_MODE_AVREAGE: presents the average value between the two
nodes.

o DATA_MODE_MIN: presents the minimum value between the two
nodes.

o DATA_MODE_A: presents the value in node A.

o DATA_MODE_B: presents the value in node B.

o DATA_MODE_ABS_MAX: presents the absolute value of the maximum
value between the two nodes.

o DATA_MODE_ABS_MIN: presents the absolute value of the minimum
value between the two nodes.
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Separate tabs
in separate tabs.
Save def.

3.2 Element(s) tab
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If a range of ID-numbers are specified, this option enables to present the results

Enables to save custom setting for the Query properties.

Having set the Query properties and proceeded by choosing OK, new tab(s) is generated in the Main
view presenting the specified results. Figure 8 gives an example where two .AVS-files are loaded, and
the axial forces in element number 513 is plotted. The values are presented in tabular form at the
top, and graphically as a function of the simulated time-steps below.

Ed [Application.title not specified]

File Analysis Data Help

Statuz  Element(s) tab

Elerment 513, Local_section_forces. Axial. .. Element 513, Local_section_forces. Axial...
2 11943 11948
3 12243 33092
4 13506 34150
5 15664 131640
(] 13245 167400
7 13285 167150
3 13066 167160
9 17635 167710
10 17530 168480
11 17318 169080 W
200 000 -
- -
150 000 /
/
= /
= 100 000 ,."Ill
{
50 000 ."I’J

Figure 8 Element(s) tab

To view larger part of the tabular results, simply place the cursor at the at the line between the table
and the graph, click and drag down. The option Copy to clipboard enables to transfer data to e.g.

Microsoft Excel. Close the pane exits the active Element(s) tab.
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3.2.1 Configure chart

Selecting Configure chart opens a window, Edit analysis, Figure 9. The different options in this
window is presented in Table 3.

gj Edit analysis

Dataset name |Axial_force_mooring_line

Element 513, Local_section_forces. Axial _force_ G

_section_forces. Axial_force_[N][0]{run_01.AVS)
Element 513, Local_section_forces, Axial_force_|

Axis  Right

OK

Figure 9 Configure chart window

Table 3 Options under Configure chart

Options Definition

Dataset name Customize the name of the dataset.

Label To generate secondary axis (for two or more datasets), choose the desired dataset

from the list to the left. The chosen dataset is automatically shown in Label.

Choose between Right or Left. This defines if the secondary axis is presented to the
left or right in the graphically view.

Axis
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